PHP < 4.4.4 Multiple Vulnerabilities

High Nessus Plugin ID 17710

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is older than 4.4.4. As such, it is potentially affected by the following vulnerabilities :

- The c-client library 2000, 2001, or 2004 for PHP does not check the safe_mode or open_basedir functions.
(CVE-2006-1017)

- A buffer overflow exists in the sscanf function.
(CVE-2006-4020)

Solution

Upgrade to PHP version 4.4.4 or later.

See Also

https://bugs.php.net/bug.php?id=38322

http://www.php.net/releases/4_4_4.php

Plugin Details

Severity: High

ID: 17710

File Name: php_4_4_4.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2011/11/18

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2006/01/12

Vulnerability Publication Date: 2006/01/11

Reference Information

CVE: CVE-2006-1017, CVE-2006-4020

BID: 16878, 19415