OpenSSH < 3.4p1 scp Traversal Arbitrary File Overwrite

Medium Nessus Plugin ID 17701


A file transfer client on the remote host could be abused to overwrite arbitrary files.


According to its banner, the version of OpenSSH running on the remote host is earlier than version 3.4p1. Such versions contain an arbitrary file overwrite vulnerability that could allow a malicious SSH server to cause the supplied scp utility to write to arbitrary files outside of the current directory.


Upgrade to OpenSSH 3.4p1 or later.

See Also

Plugin Details

Severity: Medium

ID: 17701

File Name: openssh_34p1.nasl

Version: $Revision: 1.5 $

Type: remote

Family: Misc.

Published: 2011/11/18

Modified: 2016/12/07

Dependencies: 10267

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/PCI_DSS

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2004/04/01

Vulnerability Publication Date: 2004/04/06

Reference Information

CVE: CVE-2004-0175

BID: 9986

OSVDB: 9550

CWE: 22