Amazon Linux 2023 : libssh, libssh-config, libssh-devel (ALAS2023-2023-186)

medium Nessus Plugin ID 176977

Synopsis

The remote Amazon Linux 2023 host is missing a security update.

Description

It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2023-2023-186 advisory.

- A NULL pointer dereference was found In libssh during re-keying with algorithm guessing. This issue may allow an authenticated client to cause a denial of service. (CVE-2023-1667)

- A vulnerability was found in libssh, where the authentication check of the connecting client can be bypassed in the`pki_verify_data_signature` function in memory allocation problems. This issue may happen if there is insufficient memory or the memory usage is limited. The problem is caused by the return value `rc,` which is initialized to SSH_ERROR and later rewritten to save the return value of the function call `pki_key_check_hash_compatible.` The value of the variable is not changed between this point and the cryptographic verification. Therefore any error between them calls `goto error` returning SSH_OK.
(CVE-2023-2283)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Run 'dnf update libssh --releasever 2023.0.20230607' to update your system.

See Also

https://alas.aws.amazon.com/AL2023/ALAS-2023-186.html

https://alas.aws.amazon.com/cve/html/CVE-2023-1667.html

https://alas.aws.amazon.com/cve/html/CVE-2023-2283.html

https://alas.aws.amazon.com/faqs.html

Plugin Details

Severity: Medium

ID: 176977

File Name: al2023_ALAS2023-2023-186.nasl

Version: 1.3

Type: local

Agent: unix

Published: 6/8/2023

Updated: 12/22/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2023-2283

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:amazon:linux:2023, p-cpe:/a:amazon:linux:libssh, p-cpe:/a:amazon:linux:libssh-debuginfo, p-cpe:/a:amazon:linux:libssh-debugsource, p-cpe:/a:amazon:linux:libssh-config, p-cpe:/a:amazon:linux:libssh-devel

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/25/2023

Vulnerability Publication Date: 5/11/2023

Reference Information

CVE: CVE-2023-1667, CVE-2023-2283

IAVA: 2023-A-0517-S