Amazon Linux 2 : apache-commons-io (ALAS-2023-2059)

medium Nessus Plugin ID 176708

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of apache-commons-io installed on the remote host is prior to 2.4-12. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2023-2059 advisory.

- In Apache Commons IO before 2.7, When invoking the method FileNameUtils.normalize with an improper input string, like //../foo, or \\..\foo, the result would be the same value, thus possibly providing access to files in the parent directory, but not further above (thus limited path traversal), if the calling code would use the result to construct a path value. (CVE-2021-29425)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update apache-commons-io' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2023-2059.html

https://alas.aws.amazon.com/cve/html/CVE-2021-29425.html

https://alas.aws.amazon.com/faqs.html

Plugin Details

Severity: Medium

ID: 176708

File Name: al2_ALAS-2023-2059.nasl

Version: 1.1

Type: local

Agent: unix

Published: 6/5/2023

Updated: 6/6/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2021-29425

CVSS v3

Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:amazon:linux:2, p-cpe:/a:amazon:linux:apache-commons-io-javadoc, p-cpe:/a:amazon:linux:apache-commons-io

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/25/2023

Vulnerability Publication Date: 4/13/2021

Reference Information

CVE: CVE-2021-29425