GitLab 13.2.4 < 15.10.8 / 15.11 < 15.11.7 / 16.0 < 16.0.2 (CVE-2023-0121)

high Nessus Plugin ID 176693

Synopsis

The version of GitLab installed on the remote host is affected by a vulnerability.

Description

The version of GitLab installed on the remote host is affected by a vulnerability, as follows:

- A denial of service issue was discovered in GitLab CE/EE affecting all versions starting from 13.2.4 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2 which allows an attacker to cause high resource consumption using malicious test report artifacts.
(CVE-2023-0121)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to GitLab version 15.10.8, 15.11.7, 16.0.2 or later.

See Also

http://www.nessus.org/u?27a5721a

https://gitlab.com/gitlab-org/gitlab/-/issues/387549

https://hackerone.com/reports/1774688

Plugin Details

Severity: High

ID: 176693

File Name: gitlab_cve-2023-0121.nasl

Version: 1.6

Type: combined

Agent: unix

Family: CGI abuses

Published: 6/5/2023

Updated: 5/17/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2023-0121

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 6/5/2023

Vulnerability Publication Date: 6/5/2023

Reference Information

CVE: CVE-2023-0121

IAVA: 2023-A-0275-S