GLSA-200503-35 : Smarty: Template vulnerability

High Nessus Plugin ID 17665


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200503-35 (Smarty: Template vulnerability)

A vulnerability has been discovered within the regex_replace modifier of the Smarty templates when allowing access to untrusted users.
Furthermore, it was possible to call functions from {if} statements and {math} functions.
Impact :

These issues may allow a remote attacker to bypass the 'template security' feature of Smarty, and execute arbitrary PHP code.
Workaround :

Do not grant template access to untrusted users.


All Smarty users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-php/smarty-2.6.9'

See Also

Plugin Details

Severity: High

ID: 17665

File Name: gentoo_GLSA-200503-35.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/04/01

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:smarty, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/03/30

Vulnerability Publication Date: 2005/03/23

Reference Information

CVE: CVE-2005-0913

OSVDB: 15081

GLSA: 200503-35