Joomla 4.2.x < 4.3.2 Multiple Vulnerabilities (5887-joomla-4-3-2-security-and-bug-fix-release)

high Nessus Plugin ID 176486


A PHP application running on the remote web server is affected by multiple vulnerabilities.


According to its self-reported version, the instance of Joomla! running on the remote web server is 4.2.x prior to 4.3.2. It is, therefore, affected by multiple vulnerabilities.

- An issue was discovered in Joomla! 4.2.0 through 4.3.1. Lack of input validation caused an open redirect and XSS issue within the new mfa selection screen. (CVE-2023-23754)

- An issue was discovered in Joomla! 4.2.0 through 4.3.1. The lack of rate limiting allowed brute force attacks against MFA methods. (CVE-2023-23755)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 4.3.2 or later.

See Also

Plugin Details

Severity: High

ID: 176486

File Name: joomla_432.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 5/30/2023

Updated: 6/7/2023

Configuration: Enable paranoid mode, Enable thorough checks

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2023-23755


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:joomla:joomla%5c%21

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/Joomla!

Exploit Ease: No known exploits are available

Patch Publication Date: 5/29/2023

Vulnerability Publication Date: 5/29/2023

Reference Information

CVE: CVE-2023-23754, CVE-2023-23755

IAVA: 2023-A-0269