XMB Forum < 1.9.10 Multiple Vulnerabilities

high Nessus Plugin ID 17608

Synopsis

The remote web server hosts a PHP application that is affected by multiple issues.

Description

The remote host is running XMB Forum, a web forum written in PHP.

According to its banner, the version of XMB installed on the remote host suffers from cross-site scripting, SQL injection, and input validation vulnerabilities.

Solution

Upgrade to XMB 1.9.10 or later.

See Also

https://seclists.org/bugtraq/2005/Aug/132

http://http://forums.xmbforum.com/viewthread.php?tid=773046

http://forums.xmbforum.com/viewthread.php?tid=764607

Plugin Details

Severity: High

ID: 17608

File Name: xmb_multiple_xss.nasl

Version: 1.23

Type: remote

Family: CGI abuses

Published: 3/24/2005

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 5.3

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Patch Publication Date: 3/1/2006

Vulnerability Publication Date: 3/22/2005

Reference Information

CVE: CVE-2005-0885, CVE-2005-2574, CVE-2005-2575

BID: 12886, 14523

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990