Vim < 9.0.1499 DoS

medium Nessus Plugin ID 176066


A text editor installed on the remote Windows host is affected a denial of service vulnerability.


According to its version, the version of Vim installed on the remote Windows host is prior to 9.0.1499. It is, therefore affected by a denial of service vulnerability via an out-of-range pointer offset.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Vim version 9.0.1499 or later

See Also

Plugin Details

Severity: Medium

ID: 176066

File Name: vim_9_0_1499.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 5/18/2023

Updated: 6/16/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:S/C:N/I:N/A:C

CVSS Score Source: CVE-2023-2426


Risk Factor: Medium

Base Score: 5.5

Temporal Score: 5

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vim:vim

Required KB Items: SMB/Registry/Enumerated, installed_sw/Vim

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/29/2023

Vulnerability Publication Date: 4/29/2023

Reference Information

CVE: CVE-2023-2426

IAVB: 2023-B-0035-S