RHEL 4 : libexif (RHSA-2005:300)

Low Nessus Plugin ID 17591


The remote Red Hat host is missing one or more security updates.


Updated libexif packages that fix a buffer overflow issue are now available.

This update has been rated as having low security impact by the Red Hat Security Response Team.

The libexif package contains the EXIF library. Applications use this library to parse EXIF image files.

A bug was found in the way libexif parses EXIF tags. An attacker could create a carefully crafted EXIF image file which could cause image viewers linked against libexif to crash. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CVE-2005-0664 to this issue.

Users of libexif should upgrade to these updated packages, which contain a backported patch and are not vulnerable to this issue.


Update the affected libexif and / or libexif-devel packages.

See Also



Plugin Details

Severity: Low

ID: 17591

File Name: redhat-RHSA-2005-300.nasl

Version: $Revision: 1.17 $

Type: local

Agent: unix

Published: 2005/03/21

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:libexif, p-cpe:/a:redhat:enterprise_linux:libexif-devel, cpe:/o:redhat:enterprise_linux:4

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2005/03/21

Vulnerability Publication Date: 2005/03/07

Reference Information

CVE: CVE-2005-0664

OSVDB: 14607

RHSA: 2005:300