GLSA-200503-27 : Xzabite dyndnsupdate: Multiple vulnerabilities

High Nessus Plugin ID 17588


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200503-27 (Xzabite dyndnsupdate: Multiple vulnerabilities)

Toby Dickenson discovered that dyndnsupdate suffers from multiple overflows.
Impact :

A remote attacker, posing as a server, could execute arbitrary code with the rights of the user running dyndnsupdate.
Workaround :

There is no known workaround at this time.


Currently, there is no released version of dyndnsupdate that contains a fix for these issues. The original distribution site is dead, the code contains several other problems and more secure alternatives exist, such as the net-dns/ddclient package. Therefore, the dyndnsupdate package has been hard-masked prior to complete removal from Portage, and current users are advised to unmerge the package:
# emerge --unmerge net-misc/dyndnsupdate

See Also

Plugin Details

Severity: High

ID: 17588

File Name: gentoo_GLSA-200503-27.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/03/21

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:dyndnsupdate, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/03/21

Vulnerability Publication Date: 2005/03/21

Reference Information

CVE: CVE-2005-0830

OSVDB: 14914

GLSA: 200503-27