GLSA-202305-23 : Lua: Multiple Vulnerabilities

critical Nessus Plugin ID 175055


The remote host is affected by the vulnerability described in GLSA-202305-23 (Lua: Multiple Vulnerabilities)

- Buffer overflow in the vararg functions in ldo.c in Lua 5.1 through 5.2.x before 5.2.3 allows context- dependent attackers to cause a denial of service (crash) via a small number of arguments to a function with a large number of fixed arguments. (CVE-2014-5461)

- Lua v5.4.3 and above are affected by SEGV by type confusion in funcnamefromcode function in ldebug.c which can cause a local denial of service. (CVE-2021-44647)

- singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code. (CVE-2022-28805)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


All Lua 5.1 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-lang/lua-5.1.5-r200 All Lua 5.3 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-lang/lua-5.2.3 All Lua 5.4 users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-lang/lua-5.4.4-r103

See Also

Plugin Details

Severity: Critical

ID: 175055

File Name: gentoo_GLSA-202305-23.nasl

Version: 1.1

Type: local

Published: 5/3/2023

Updated: 5/4/2023

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.0


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS Score Source: CVE-2022-28805


Risk Factor: Critical

Base Score: 9.1

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:lua, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 5/3/2023

Vulnerability Publication Date: 8/21/2014

Reference Information

CVE: CVE-2014-5461, CVE-2021-44647, CVE-2022-28805