Jenkins Enterprise and Operations Center 2.346.x < 2.346.40.0.16 Multiple Vulnerabilities (CloudBees Security Advisory 2023-05-03-security-advisory)

high Nessus Plugin ID 175050

Synopsis

A job scheduling and management system hosted on the remote web server is affected by multiple vulnerabilities.

Description

The version of Jenkins Enterprise or Jenkins Operations Center running on the remote web server is 2.346.x prior to 2.346.40.0.16. It is, therefore, affected by multiple vulnerabilities including the following:

- Backup Jobs Can Be Broken by Low-Privilege User With Job/Configure (BEE-29576Severity (CVSS):)

- Low-Privilege Users to Run Restores at Will (BEE-29577Severity (CVSS):)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Jenkins Enterprise or Jenkins Operations Center to version 2.346.40.0.16 or later.

See Also

http://www.nessus.org/u?1d224b27

Plugin Details

Severity: High

ID: 175050

File Name: cloudbees-security-advisory-2023-05-03-security-advisory.nasl

Version: 1.1

Type: combined

Agent: windows, macosx, unix

Family: CGI abuses

Published: 5/3/2023

Updated: 6/4/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Vulnerability Information

CPE: cpe:/a:cloudbees:jenkins

Required KB Items: installed_sw/Jenkins

Exploit Ease: No known exploits are available

Patch Publication Date: 5/3/2023

Vulnerability Publication Date: 5/3/2023