Contec CONPROSYS HMI System (CHS) SQL Injection (CVE-2023-1658)

high Nessus Plugin ID 174122

Synopsis

A web application is affected by an SQL injection vulnerability.

Description

The Contec CONPROSYS HMI System (CHS) running on the remote host is affected by an SQL injection vulnerability. An unauthenticated, remote attacker can exploit this, via specially crafted messages, to enumerate a CHS database.

Solution

Upgrade CONPROSYS HMI System (CHS) to version 3.5.2 or later.

See Also

https://jvn.jp/vu/JVNVU92145493/

Plugin Details

Severity: High

ID: 174122

File Name: contec_chs_cve-2023-1658.nbin

Version: 1.20

Type: remote

Family: SCADA

Published: 4/11/2023

Updated: 5/20/2024

Supported Sensors: Nessus

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2023-1658

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:contec:conprosys_hmi_system

Required KB Items: installed_sw/Contec CONPROSYS HMI System

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 3/17/2022

Vulnerability Publication Date: 3/31/2023

Reference Information

CVE: CVE-2023-1658