Node.js Module vm2 < 3.9.15 Sandbox Breakout

critical Nessus Plugin ID 174021

Synopsis

A module in the Node.js JavaScript run-time environment is affected by a sandbox breakout vulnerability.

Description

The version of the Node.js module vm2 installed on the remote host is prior to 3.9.15. It is, therefore affected by a sandbox breakout vulnerability. Untrusted code can break out of the sandbox created by the affected vm2 module and execute arbitrary code on the host system.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to vm2 version 3.9.15 or later.

See Also

https://github.com/patriksimek/vm2/issues/515

http://www.nessus.org/u?5ab9f9b6

Plugin Details

Severity: Critical

ID: 174021

File Name: nodejs_module_vm2_3_9_15.nasl

Version: 1.5

Type: local

Agent: windows

Family: Misc.

Published: 4/7/2023

Updated: 6/6/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Critical

Score: 9.0

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-29017

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vm2_project:vm2

Required KB Items: Host/nodejs/modules/enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/6/2023

Vulnerability Publication Date: 4/6/2023

Reference Information

CVE: CVE-2023-29017