Debian DLA-3381-1 : ghostscript - LTS security update

critical Nessus Plugin ID 173849

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 host has packages installed that are affected by a vulnerability as referenced in the dla-3381 advisory.

- In Artifex Ghostscript through 10.01.0, there is a buffer overflow leading to potential corruption of data internal to the PostScript interpreter, in base/sbcp.c. This affects BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode. If the write buffer is filled to one byte less than full, and one then tries to write an escaped character, two bytes are written. (CVE-2023-28879)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the ghostscript packages.

For Debian 10 Buster, this problem has been fixed in version 9.27~dfsg-2+deb10u7.

See Also

https://www.debian.org/lts/security/2023/dla-3381

https://security-tracker.debian.org/tracker/CVE-2023-28879

https://packages.debian.org/source/buster/ghostscript

Plugin Details

Severity: Critical

ID: 173849

File Name: debian_DLA-3381.nasl

Version: 1.6

Type: local

Agent: unix

Published: 4/4/2023

Updated: 9/28/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-28879

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript, p-cpe:/a:debian:debian_linux:ghostscript-dbg, p-cpe:/a:debian:debian_linux:ghostscript-doc, p-cpe:/a:debian:debian_linux:ghostscript-x, p-cpe:/a:debian:debian_linux:libgs-dev, p-cpe:/a:debian:debian_linux:libgs9, p-cpe:/a:debian:debian_linux:libgs9-common, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 4/4/2023

Vulnerability Publication Date: 3/31/2023

Reference Information

CVE: CVE-2023-28879

IAVB: 2023-B-0023-S