Jetty < 4.2.19 HTTP Server Content-Length Handling Remote Overflow DoS

Medium Nessus Plugin ID 17348


The remote web server is prone to a denial of service attack.


According to its banner, the remote host is running a version of Jetty that is older than 4.2.19. The version is vulnerable to a unspecified denial of service.


Upgrade to version 4.2.19 or later.

See Also

Plugin Details

Severity: Medium

ID: 17348

File Name: jetty_4_1_9_dos.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2005/03/17

Modified: 2011/09/14

Dependencies: 10107

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mortbay:jetty

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2004/03/19

Reference Information

CVE: CVE-2004-2381

BID: 9917

OSVDB: 4387