Mandrake Linux Security Advisory : gftp (MDKSA-2005:050)

Medium Nessus Plugin ID 17279


The remote Mandrake Linux host is missing a security update.


A vulnerability in gftp could allow a malicious FTP server to overwrite files on the local system as the user running gftp due to improper handling of filenames containing slashes.

The updated packages are patched to deal with these issues.


Update the affected gftp package.

Plugin Details

Severity: Medium

ID: 17279

File Name: mandrake_MDKSA-2005-050.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/03/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gftp, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/03/04

Reference Information

CVE: CVE-2005-0372

MDKSA: 2005:050