Mandrake Linux Security Advisory : gaim (MDKSA-2005:049)

Medium Nessus Plugin ID 17278


The remote Mandrake Linux host is missing one or more security updates.


Gaim versions prior to version 1.1.4 suffer from a few security issues such as the HTML parses not sufficiently validating its input. This allowed a remote attacker to crash the Gaim client be sending certain malformed HTML messages (CVE-2005-0208 and CVE-2005-0473).

As well, insufficient input validation was also discovered in the 'Oscar' protocol handler, used for ICQ and AIM. By sending specially crafted packets, remote users could trigger an inifinite loop in Gaim causing it to become unresponsive and hang (CVE-2005-0472).

Gaim 1.1.4 is provided and fixes these issues.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 17278

File Name: mandrake_MDKSA-2005-049.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/03/06

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:gaim, p-cpe:/a:mandriva:linux:gaim-devel, p-cpe:/a:mandriva:linux:gaim-gevolution, p-cpe:/a:mandriva:linux:gaim-perl, p-cpe:/a:mandriva:linux:gaim-tcl, p-cpe:/a:mandriva:linux:lib64gaim-remote0, p-cpe:/a:mandriva:linux:lib64gaim-remote0-devel, p-cpe:/a:mandriva:linux:libgaim-remote0, p-cpe:/a:mandriva:linux:libgaim-remote0-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/03/04

Reference Information

CVE: CVE-2005-0208, CVE-2005-0472, CVE-2005-0473

MDKSA: 2005:049