Drupal 7.x < 7.95 / 9.4.x < 9.4.12 / 9.5.x < 9.5.5 / 10.x < 10.0.5 Multiple Vulnerabilities (drupal-2023-03-15)

high Nessus Plugin ID 172584


A PHP application running on the remote web server is affected by multiple vulnerabilities.


According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.95, 9.4.x prior to 9.4.12, 9.5.x prior to 9.5.5, or 10.x prior to 10.0.5. It is, therefore, affected by multiple vulnerabilities.

- Drupal core provides a page that outputs the markup from phpinfo() to assist with diagnosing PHP configuration. If an attacker was able to achieve an XSS exploit against a privileged user, they may be able to use the phpinfo page to access sensitive information that could be used to escalate the attack.
This vulnerability is mitigated by the fact that a successful XSS exploit is required in order to exploit it. (SA-CORE-2023-004)

- The language module provides a Language switcher block which can be placed to provide links to quickly switch between different languages. The URL of unpublished translations may be disclosed. When used in conjunction with a module like Pathauto, this may reveal the title of unpublished content. This advisory is not covered by Drupal Steward. (SA-CORE-2023-003)

- The Media module does not properly check entity access in some circumstances. This may result in users seeing thumbnails of media items they do not have access to, including for private files. This release was coordinated with SA-CONTRIB-2023-010. This advisory is not covered by Drupal Steward. (SA-CORE-2023-002)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Drupal version 7.95 / 9.4.12 / 9.5.5 / 10.0.5 or later.

See Also











Plugin Details

Severity: High

ID: 172584

File Name: drupal_10_0_5.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 3/15/2023

Updated: 3/27/2023

Configuration: Enable paranoid mode, Enable thorough checks

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/15/2023

Vulnerability Publication Date: 3/15/2023

Reference Information

IAVA: 2023-A-0151-S