GLSA-200502-33 : MediaWiki: Multiple vulnerabilities

High Nessus Plugin ID 17236


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200502-33 (MediaWiki: Multiple vulnerabilities)

A security audit of the MediaWiki project discovered that MediaWiki is vulnerable to several cross-site scripting and cross-site request forgery attacks, and that the image deletion code does not sufficiently sanitize input parameters.
Impact :

By tricking a user to load a carefully crafted URL, a remote attacker could hijack sessions and authentication cookies to inject malicious script code that will be executed in a user's browser session in context of the vulnerable site, or use JavaScript submitted forms to perform restricted actions. Using the image deletion flaw, it is also possible for authenticated administrators to delete arbitrary files via directory traversal.
Workaround :

There is no known workaround at this time.


All MediaWiki users should upgrade to the latest available version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-apps/mediawiki-1.3.11'

See Also

Plugin Details

Severity: High

ID: 17236

File Name: gentoo_GLSA-200502-33.nasl

Version: $Revision: 1.14 $

Type: local

Published: 2005/03/01

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:mediawiki, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/02/28

Vulnerability Publication Date: 2005/02/03

Reference Information

CVE: CVE-2005-0534, CVE-2005-0535, CVE-2005-0536

OSVDB: 13469, 14048, 14049, 14050

GLSA: 200502-33