Foxit PDF Editor < 12.1.1 Multiple Vulnerabilities

critical Nessus Plugin ID 172190

Synopsis

A PDF toolkit installed on the remote Windows host is affected by multiple vulnerabilities

Description

According to its version, the Foxit PDF Editor application (previously named Foxit PhantomPDF) installed on the remote Windows host is prior to 12.1.1. It is, therefore affected by multiple vulnerabilities:

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Foxit PDF Editor version 12.1.1 or later

See Also

http://www.nessus.org/u?a27a3e57

Plugin Details

Severity: Critical

ID: 172190

File Name: foxit_pdf_editor_12_1_1.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 3/7/2023

Updated: 10/9/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2023-27331

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:foxitsoftware:phantom, cpe:/a:foxitsoftware:phantompdf

Required KB Items: installed_sw/FoxitPhantomPDF, SMB/Registry/Enumerated

Exploit Ease: No known exploits are available

Patch Publication Date: 2/21/2023

Vulnerability Publication Date: 2/21/2023

Reference Information

CVE: CVE-2023-27329, CVE-2023-27330, CVE-2023-27331

IAVA: 2023-A-0128-S