Firefox < 1.0.1 Multiple Vulnerabilities

High Nessus Plugin ID 17218


The remote Windows host contains a web browser that is affected by multiple vulnerabilities.


The installed version of Firefox is earlier than 1.0.1. Such versions have multiple security issues, including vulnerabilities that could allow an attacker to impersonate a website by using an International Domain Name, or vulnerabilities that could allow arbitrary code execution.


Upgrade to Firefox 1.0.1 or later.

See Also

Plugin Details

Severity: High

ID: 17218

File Name: mozilla_firefox_101.nasl

Version: 1.28

Type: local

Agent: windows

Family: Windows

Published: 2005/02/25

Updated: 2018/07/16

Dependencies: 20862

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mozilla:firefox

Required KB Items: Mozilla/Firefox/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2005/02/25

Vulnerability Publication Date: 2004/04/23

Reference Information

CVE: CVE-2004-1200, CVE-2005-0230, CVE-2005-0233, CVE-2005-0255, CVE-2005-0578, CVE-2005-0584, CVE-2005-0586, CVE-2005-0587, CVE-2005-0588, CVE-2005-0589, CVE-2005-0590, CVE-2005-0591, CVE-2005-0592, CVE-2005-0593

BID: 12533, 12461, 12470, 12468, 12466, 12465, 12234, 12153, 11854, 11823, 11752, 12655, 12659, 12728