Debian DLA-3350-1 : node-css-what - LTS security update

high Nessus Plugin ID 172087


The remote Debian host is missing one or more security-related updates.


The remote Debian 10 host has a package installed that is affected by multiple vulnerabilities as referenced in the dla-3350 advisory.

- The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input. (CVE-2021-33587)

- The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function. (CVE-2022-21222)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade the node-css-what packages.

For Debian 10 buster, this problem has been fixed in version 2.1.0-1+deb10u1.

See Also

Plugin Details

Severity: High

ID: 172087

File Name: debian_DLA-3350.nasl

Version: 1.1

Type: local

Agent: unix

Published: 3/3/2023

Updated: 8/31/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2021-33587


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS Score Source: CVE-2022-21222

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:node-css-what, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/3/2023

Vulnerability Publication Date: 5/28/2021

Reference Information

CVE: CVE-2021-33587, CVE-2022-21222