Ubuntu 20.04 LTS / 22.04 LTS : lighttpd vulnerabilities (USN-5903-1)

high Nessus Plugin ID 172024


The remote Ubuntu host is missing one or more security updates.


The remote Ubuntu 20.04 LTS / 22.04 LTS / 22.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5903-1 advisory.

- In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system. (CVE-2022-22707)

- A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected.
This is fixed in 1.4.67. (CVE-2022-41556)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Update the affected packages.

See Also


Plugin Details

Severity: High

ID: 172024

File Name: ubuntu_USN-5903-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 3/1/2023

Updated: 10/23/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2022-22707


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

CVSS Score Source: CVE-2022-41556

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:lighttpd, p-cpe:/a:canonical:ubuntu_linux:lighttpd-dev, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-authn-gssapi, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-authn-pam, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-authn-sasl, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-cml, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-deflate, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-geoip, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-magnet, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-maxminddb, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-mbedtls, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-nss, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-openssl, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-trigger-b4-dl, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-vhostdb-dbi, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-vhostdb-pgsql, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-webdav, p-cpe:/a:canonical:ubuntu_linux:lighttpd-mod-wolfssl, p-cpe:/a:canonical:ubuntu_linux:lighttpd-modules-dbi, p-cpe:/a:canonical:ubuntu_linux:lighttpd-modules-ldap, p-cpe:/a:canonical:ubuntu_linux:lighttpd-modules-lua, p-cpe:/a:canonical:ubuntu_linux:lighttpd-modules-mysql

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/28/2023

Vulnerability Publication Date: 1/6/2022

Reference Information

CVE: CVE-2022-22707, CVE-2022-41556

USN: 5903-1