Debian DLA-3347-1 : spip - LTS security update

critical Nessus Plugin ID 171958


The remote Debian host is missing one or more security-related updates.


The remote Debian 10 host has a package installed that is affected by a vulnerability as referenced in the dla-3347 advisory.

- SPIP before 4.2.1 allows Remote Code Execution via form values in the public area because serialization is mishandled. The fixed versions are 3.2.18, 4.0.10, 4.1.8, and 4.2.1. (CVE-2023-27372)

- SPIP v4.1.5 and earlier was discovered to contain a SQL injection vulnerability via the _oups parameter.
This vulnerability allows attackers to execute arbitrary code via a crafted POST request. (CVE-2023-24258)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the spip packages.

For Debian 10 buster, this problem has been fixed in version 3.2.4-1+deb10u10.

See Also

Plugin Details

Severity: Critical

ID: 171958

File Name: debian_DLA-3347.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2/28/2023

Updated: 4/18/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

Risk Information


Risk Factor: Critical

Score: 9.0


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2023-27372


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:spip, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/27/2023

Vulnerability Publication Date: 2/27/2023

Exploitable With

Metasploit (SPIP form PHP Injection)

Reference Information

CVE: CVE-2023-24258, CVE-2023-27372