Joomla 4.0.x < 4.2.8 Joomla 4.2.8 Security Release (5878-joomla-4-2-8-security-release)

medium Nessus Plugin ID 171551


A PHP application running on the remote web server is affected by a vulnerability.


According to its self-reported version, the instance of Joomla! running on the remote web server is 4.0.x prior to 4.2.8. It is, therefore, affected by a vulnerability.

- An improper access check allows unauthorized access to webservice endpoints. (CVE-2023-23752)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 4.2.8 or later.

See Also

Plugin Details

Severity: Medium

ID: 171551

File Name: joomla_428.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2/16/2023

Updated: 6/5/2024

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Low

Score: 2.9


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2023-23752


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:joomla:joomla%5c%21

Required KB Items: www/PHP, Settings/ParanoidReport, installed_sw/Joomla!

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/16/2023

Vulnerability Publication Date: 2/16/2023

CISA Known Exploited Vulnerability Due Dates: 1/29/2024

Reference Information

CVE: CVE-2023-23752

IAVA: 2023-A-0109-S