GLSA-200502-27 : gFTP: Directory traversal vulnerability

Medium Nessus Plugin ID 17153


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-200502-27 (gFTP: Directory traversal vulnerability)

gFTP lacks input validation of filenames received by remote servers.
Impact :

An attacker could entice a user to connect to a malicious FTP server and conduct a directory traversal attack by making use of specially crafted filenames. This could lead to arbitrary files being created or overwritten.
Workaround :

There is no known workaround at this time.


All gFTP users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-ftp/gftp-2.0.18-r1'

See Also

Plugin Details

Severity: Medium

ID: 17153

File Name: gentoo_GLSA-200502-27.nasl

Version: $Revision: 1.13 $

Type: local

Published: 2005/02/20

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gftp, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2005/02/19

Vulnerability Publication Date: 2005/02/10

Reference Information

CVE: CVE-2005-0372

OSVDB: 13669

GLSA: 200502-27