Mandrake Linux Security Advisory : kdelibs (MDKSA-2005:045)

High Nessus Plugin ID 17140


The remote Mandrake Linux host is missing one or more security updates.


A bug in the way kioslave handles URL-encoded newline (%0a) characters before the FTP command was discovered. Because of this, it is possible that a specially crafted URL could be used to execute any ftp command on a remote server, or even send unsolicited email.

As well, Davide Madrisan discovered that dcopidlng created temporary files in an insecure manner.

The updated packages are patched to deal with these issues.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 17140

File Name: mandrake_MDKSA-2005-045.nasl

Version: $Revision: 1.15 $

Type: local

Published: 2005/02/18

Modified: 2013/05/31

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:kdelibs-common, p-cpe:/a:mandriva:linux:lib64kdecore4, p-cpe:/a:mandriva:linux:lib64kdecore4-devel, p-cpe:/a:mandriva:linux:libkdecore4, p-cpe:/a:mandriva:linux:libkdecore4-devel, cpe:/o:mandrakesoft:mandrake_linux:10.0, cpe:/o:mandrakesoft:mandrake_linux:10.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Patch Publication Date: 2005/02/17

Reference Information

CVE: CVE-2004-1165, CVE-2005-0365

MDKSA: 2005:045