GitLab < 15.6.7 / 15.7 < 15.7.6 / 15.8 < 15.8.1 (CVE-2022-4138)

high Nessus Plugin ID 170954


The GitLab instance installed on the remote host is affected by vulnerability.


The version of GitLab installed on the remote host is prior to 15.6.7, 15.7.6, 15.8.1. It is, therefore, affected by a vulnerability as referenced in the SECURITY-RELEASE-GITLAB-15-8-1-RELEASED advisory.

- A Cross Site Request Forgery issue has been discovered in GitLab CE/EE affecting all versions before 15.6.7, all versions starting from 15.7 before 15.7.6, and all versions starting from 15.8 before 15.8.1.
An attacker could take over a project if an Owner or Maintainer uploads a file to a malicious project.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to GitLab version 15.6.7, 15.7.6, 15.8.1 or later.

See Also

Plugin Details

Severity: High

ID: 170954

File Name: gitlab_CVE-2022-4138.nasl

Version: 1.3

Type: combined

Agent: unix

Family: CGI abuses

Published: 2/2/2023

Updated: 3/10/2023

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information


Risk Factor: Medium

Score: 5.2


Risk Factor: High

Base Score: 9.4

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-4138


Risk Factor: High

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:gitlab:gitlab

Required KB Items: installed_sw/GitLab

Exploit Ease: No known exploits are available

Patch Publication Date: 1/31/2023

Vulnerability Publication Date: 1/31/2023

Reference Information

CVE: CVE-2022-4138

IAVA: 2023-A-0077-S