Debian DLA-3301-1 : cinder - LTS security update

medium Nessus Plugin ID 170886

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 host has packages installed that are affected by a vulnerability as referenced in the dla-3301 advisory.

- An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and Nova before 24.1.2, 25.x before 25.0.2, and 26.0.0. By supplying a specially created VMDK flat image that references a specific backing file path, an authenticated user may convince systems to return a copy of that file's contents from the server, resulting in unauthorized access to potentially sensitive data. (CVE-2022-47951)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the cinder packages.

For Debian 10 buster, this problem has been fixed in version 2

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1029562

https://security-tracker.debian.org/tracker/source-package/cinder

https://www.debian.org/lts/security/2023/dla-3301

https://security-tracker.debian.org/tracker/CVE-2022-47951

https://packages.debian.org/source/buster/cinder

Plugin Details

Severity: Medium

ID: 170886

File Name: debian_DLA-3301.nasl

Version: 1.2

Type: local

Agent: unix

Published: 1/31/2023

Updated: 9/5/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:N/A:N

CVSS Score Source: CVE-2022-47951

CVSS v3

Risk Factor: Medium

Base Score: 5.7

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:cinder-api, p-cpe:/a:debian:debian_linux:cinder-scheduler, cpe:/o:debian:debian_linux:10.0, p-cpe:/a:debian:debian_linux:python3-cinder, p-cpe:/a:debian:debian_linux:cinder-backup, p-cpe:/a:debian:debian_linux:cinder-common, p-cpe:/a:debian:debian_linux:cinder-volume, p-cpe:/a:debian:debian_linux:cinder-doc

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/31/2023

Vulnerability Publication Date: 1/26/2023

Reference Information

CVE: CVE-2022-47951