Drupal 9.4.x < 9.4.10 / 9.5.x < 9.5.2 / 10.0.x < 10.0.2 Drupal Vulnerability (SA-CORE-2023-001)

high Nessus Plugin ID 170730


A PHP application running on the remote web server is affected by a vulnerability.


According to its self-reported version, the instance of Drupal running on the remote web server is 9.4.x prior to 9.4.10 or 9.5.x prior to 9.5.2 or 10.0.x prior to 10.0.2. It is, therefore, affected by a vulnerability.

- The Media Library module does not properly check entity access in some circumstances. This may result in users with access to edit content seeing metadata about media items they are not authorized to access. The vulnerability is mitigated by the fact that the inaccessible media will only be visible to users who can already edit content that includes a media reference field. This advisory is not covered by Drupal Steward. (SA-CORE-2023-001)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Drupal version 9.4.10 / 9.5.2 / 10.0.2 or later.

See Also







Plugin Details

Severity: High

ID: 170730

File Name: drupal_10_0_2.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 1/27/2023

Updated: 1/30/2023

Configuration: Enable paranoid mode, Enable thorough checks

Supported Sensors: Nessus

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: Settings/ParanoidReport, installed_sw/Drupal

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2023

Vulnerability Publication Date: 1/18/2023

Reference Information

IAVA: 2023-A-0052-S