Apple iOS < 16.3 Multiple Vulnerabilities (HT213606)

high Nessus Plugin ID 170573

Synopsis

The version of Apple iOS running on the mobile device is affected by multiple vulnerabilities.

Description

The version of Apple iOS running on the mobile device is prior to 16.3. It is, therefore, affected by multiple vulnerabilities, including:

- A vulnerability in the kernel that may result in an app being able to execute code with kernel privileges. (CVE-2023-23504)

- Multiple vulenrabilities in Webkit whereby processing maliciously crafted web content my result in arbitrary code execution. (CVE-2023-23496, CVE-2023-23517, CVE-2023-23518)

- A vulnerability in ImageIO where processing an image may lead to a denial of service. (CVE-2023-23519)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apple iOS version 16.3 or later

See Also

https://support.apple.com/en-us/HT213606

Plugin Details

Severity: High

ID: 170573

File Name: apple_ios_163_check.nbin

Version: 1.2

Type: local

Published: 1/25/2023

Updated: 1/27/2023

Risk Information

VPR

Risk Factor: High

Score: 8.5

CVSS v2

Risk Factor: Medium

Base Score: 6.9

Temporal Score: 5.1

Vector: AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2023-23504

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

CVSS Score Source: CVE-2023-23517

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Required KB Items: mdm/dependency/unlocked

Exploit Ease: No known exploits are available

Patch Publication Date: 1/23/2023

Vulnerability Publication Date: 1/23/2023

Reference Information

CVE: CVE-2023-23496, CVE-2023-23498, CVE-2023-23499, CVE-2023-23500, CVE-2023-23502, CVE-2023-23503, CVE-2023-23504, CVE-2023-23505, CVE-2023-23511, CVE-2023-23512, CVE-2023-23517, CVE-2023-23518, CVE-2023-23519

APPLE-SA: HT213606

IAVA: 2023-A-0053