RHEL 7 : bind (RHSA-2023:0402)

medium Nessus Plugin ID 170533

Synopsis

The remote Red Hat host is missing one or more security updates for bind.

Description

The remote Redhat Enterprise Linux 7 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2023:0402 advisory.

- bind: DNS forwarders - cache poisoning vulnerability (CVE-2021-25220)

- bind: processing large delegations may severely degrade resolver performance (CVE-2022-2795)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the RHEL bind package based on the guidance in RHSA-2023:0402.

See Also

http://www.nessus.org/u?e77a43a8

https://access.redhat.com/security/updates/classification/#moderate

https://access.redhat.com/errata/RHSA-2023:0402

https://bugzilla.redhat.com/show_bug.cgi?id=2064512

https://bugzilla.redhat.com/show_bug.cgi?id=2128584

Plugin Details

Severity: Medium

ID: 170533

File Name: redhat-RHSA-2023-0402.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/24/2023

Updated: 4/28/2024

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.2

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

CVSS Score Source: CVE-2021-25220

CVSS v3

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:7, p-cpe:/a:redhat:enterprise_linux:bind, p-cpe:/a:redhat:enterprise_linux:bind-chroot, p-cpe:/a:redhat:enterprise_linux:bind-devel, p-cpe:/a:redhat:enterprise_linux:bind-export-devel, p-cpe:/a:redhat:enterprise_linux:bind-export-libs, p-cpe:/a:redhat:enterprise_linux:bind-libs, p-cpe:/a:redhat:enterprise_linux:bind-libs-lite, p-cpe:/a:redhat:enterprise_linux:bind-license, p-cpe:/a:redhat:enterprise_linux:bind-lite-devel, p-cpe:/a:redhat:enterprise_linux:bind-pkcs11, p-cpe:/a:redhat:enterprise_linux:bind-pkcs11-devel, p-cpe:/a:redhat:enterprise_linux:bind-pkcs11-libs, p-cpe:/a:redhat:enterprise_linux:bind-pkcs11-utils, p-cpe:/a:redhat:enterprise_linux:bind-sdb, p-cpe:/a:redhat:enterprise_linux:bind-sdb-chroot, p-cpe:/a:redhat:enterprise_linux:bind-utils

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 1/24/2023

Vulnerability Publication Date: 3/16/2022

Reference Information

CVE: CVE-2021-25220, CVE-2022-2795

CWE: 400, 444

IAVA: 2022-A-0122-S, 2022-A-0387-S

RHSA: 2023:0402