Amazon Linux 2 : sqlite (ALAS-2023-1911)

high Nessus Plugin ID 170434

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

The version of sqlite installed on the remote host is prior to 3.7.17-8. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2023-1911 advisory.

- SQLite 1.0.12 through 3.39.x before 3.39.2 sometimes allows an array-bounds overflow if billions of bytes are used in a string argument to a C API. (CVE-2022-35737)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'yum update sqlite' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2023-1911.html

https://alas.aws.amazon.com/cve/html/CVE-2022-35737.html

Plugin Details

Severity: High

ID: 170434

File Name: al2_ALAS-2023-1911.nasl

Version: 1.1

Type: local

Agent: unix

Published: 1/23/2023

Updated: 9/6/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.1

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2022-35737

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:sqlite-debuginfo, p-cpe:/a:amazon:linux:sqlite-devel, cpe:/o:amazon:linux:2, p-cpe:/a:amazon:linux:sqlite-doc, p-cpe:/a:amazon:linux:sqlite-tcl, p-cpe:/a:amazon:linux:lemon, p-cpe:/a:amazon:linux:sqlite

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/18/2023

Vulnerability Publication Date: 8/3/2022

Reference Information

CVE: CVE-2022-35737

IAVA: 2022-A-0382-S