RHEL 6 / 8 : AMQ Clients 2.6.0 Release (Important) (RHSA-2020:0601)

critical Nessus Plugin ID 170341

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

The remote Redhat Enterprise Linux 6 / 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the RHSA-2020:0601 advisory.

- netty: HTTP request smuggling (CVE-2019-20444)

- netty: HttpObjectDecoder.java allows Content-Length header to accompanied by second Content-Length header (CVE-2019-20445)

- netty: HTTP Request Smuggling due to Transfer-Encoding whitespace mishandling (CVE-2020-7238)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://access.redhat.com/security/cve/CVE-2019-20444

https://access.redhat.com/security/cve/CVE-2019-20445

https://access.redhat.com/security/cve/CVE-2020-7238

https://access.redhat.com/errata/RHSA-2020:0601

https://bugzilla.redhat.com/1796225

https://bugzilla.redhat.com/1798509

https://bugzilla.redhat.com/1798524

Plugin Details

Severity: Critical

ID: 170341

File Name: redhat-RHSA-2020-0601.nasl

Version: 1.1

Type: local

Agent: unix

Published: 1/23/2023

Updated: 9/7/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.0

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2019-20445

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:redhat:enterprise_linux:6, cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:nodejs-rhea, p-cpe:/a:redhat:enterprise_linux:python-qpid-proton, p-cpe:/a:redhat:enterprise_linux:python-qpid-proton-docs, p-cpe:/a:redhat:enterprise_linux:python3-qpid-proton, p-cpe:/a:redhat:enterprise_linux:qpid-proton-c, p-cpe:/a:redhat:enterprise_linux:qpid-proton-c-devel, p-cpe:/a:redhat:enterprise_linux:qpid-proton-c-docs, p-cpe:/a:redhat:enterprise_linux:qpid-proton-cpp, p-cpe:/a:redhat:enterprise_linux:qpid-proton-cpp-devel, p-cpe:/a:redhat:enterprise_linux:qpid-proton-cpp-docs, p-cpe:/a:redhat:enterprise_linux:qpid-proton-tests, p-cpe:/a:redhat:enterprise_linux:rubygem-qpid_proton, p-cpe:/a:redhat:enterprise_linux:rubygem-qpid_proton-doc

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/25/2020

Vulnerability Publication Date: 1/27/2020

Reference Information

CVE: CVE-2019-20444, CVE-2019-20445, CVE-2020-7238

CWE: 444

RHSA: 2020:0601