GLSA-202301-07 : Alpine: Multiple Vulnerabilities

medium Nessus Plugin ID 169835

Description

The remote host is affected by the vulnerability described in GLSA-202301-07 (Alpine: Multiple Vulnerabilities)

- In Alpine before 2.25, untagged responses from an IMAP server are accepted before STARTTLS.
(CVE-2021-38370)

- Alpine before 2.25 allows remote attackers to cause a denial of service (application crash) when LIST or LSUB is sent before STARTTLS. (CVE-2021-46853)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

All Alpine users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose >=mail-client/alpine-2.25

See Also

https://security.gentoo.org/glsa/202301-07

https://bugs.gentoo.org/show_bug.cgi?id=807613

Plugin Details

Severity: Medium

ID: 169835

File Name: gentoo_GLSA-202301-07.nasl

Version: 1.0

Type: local

Published: 1/11/2023

Updated: 1/11/2023

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-38370

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:alpine, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 1/11/2023

Vulnerability Publication Date: 8/10/2021

Reference Information

CVE: CVE-2021-38370, CVE-2021-46853