Atlassian Confluence Command Injection (CONFSERVER-79016)

critical Nessus Plugin ID 169509


A web application running on the remote host is affected by a command injection vulnerability


According to its self-reported version number, the Atlassian Confluence running on the remote host is affected by a command injection vulnerability. A remote, unauthenticated attacker can use this to execute arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Atlassian Confluence version 7.4.17, 7.13.7, 7.14.3, 7.15.2, 7.16.4, 7.17.4, 7.18.1 or later.

See Also

Plugin Details

Severity: Critical

ID: 169509

File Name: atlassian_confluence_confserver-79016.nasl

Version: 1.5

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 1/4/2023

Updated: 6/5/2024

Supported Sensors: Nessus Agent, Nessus

Enable CGI Scanning: true

Risk Information


Risk Factor: Critical

Score: 9.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2022-26134


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:confluence

Required KB Items: installed_sw/Atlassian Confluence

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/2/2022

Vulnerability Publication Date: 6/2/2022

CISA Known Exploited Vulnerability Due Dates: 6/6/2022

Exploitable With


Core Impact

Metasploit (Atlassian Confluence Namespace OGNL Injection)

Reference Information

CVE: CVE-2022-26134