Samba < 4.15.13 / 4.16.x < 4.16.8 / 4.17.x < 4.17.4 Multiple Vulnerabilities

critical Nessus Plugin ID 169505


The remote Samba server is potentially affected by multiple vulnerabilities.


The version of Samba running on the remote host is prior to 4.15.13, 4.16.x prior to 4.16.8, or 4.17.x prior to 4.17.4. It is, therefore, affected by multiple vulnerabilities:

- Windows Kerberos RC4-HMAC Elevation of Privilege Vulnerability. (CVE-2022-37966, CVE-2022-45141)

- Windows Kerberos Elevation of Privilege Vulnerability. (CVE-2022-37967)

- Netlogon RPC Elevation of Privilege Vulnerability. (CVE-2022-38023)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Samba version 4.15.13, 4.16.8, or 4.17.4 or later.

See Also

Plugin Details

Severity: Critical

ID: 169505

File Name: samba_4_17_4.nasl

Version: 1.5

Type: remote

Family: Misc.

Published: 1/4/2023

Updated: 9/11/2023

Configuration: Enable paranoid mode

Risk Information


Risk Factor: High

Score: 7.4


Risk Factor: Critical

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-45141


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: Settings/ParanoidReport, SMB/samba, SMB/NativeLanManager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 12/15/2022

Vulnerability Publication Date: 1/9/2022

Reference Information

CVE: CVE-2022-37966, CVE-2022-37967, CVE-2022-38023, CVE-2022-45141

IAVA: 2023-A-0004-S