Debian DLA-3203-1 : nginx - LTS security update

high Nessus Plugin ID 168171

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 10 host has packages installed that are affected by multiple vulnerabilities as referenced in the dla-3203 advisory.

- ALPACA is an application layer protocol content confusion attack, exploiting TLS servers implementing different protocols but using compatible certificates, such as multi-domain or wildcard certificates. A MiTM attacker having access to victim's traffic at the TCP/IP layer can redirect traffic from one subdomain to another, resulting in a valid TLS session. This breaks the authentication of TLS and cross- protocol attacks may be possible where the behavior of one protocol service may compromise the other at the application layer. (CVE-2021-3618)

- NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module. (CVE-2022-41741)

- NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to cause a worker process crash, or might result in worker process memory disclosure by using a specially crafted audio or video file. The issue affects only NGINX products that are built with the module ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module. (CVE-2022-41742)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the nginx packages.

For Debian 10 buster, these problems have been fixed in version 1.14.2-2+deb10u5.

See Also

https://packages.debian.org/source/buster/nginx

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=991328

https://security-tracker.debian.org/tracker/source-package/nginx

https://www.debian.org/lts/security/2022/dla-3203

https://security-tracker.debian.org/tracker/CVE-2021-3618

https://security-tracker.debian.org/tracker/CVE-2022-41741

https://security-tracker.debian.org/tracker/CVE-2022-41742

Plugin Details

Severity: High

ID: 168171

File Name: debian_DLA-3203.nasl

Version: 1.3

Type: local

Agent: unix

Published: 11/24/2022

Updated: 11/2/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2021-3618

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

CVSS Score Source: CVE-2022-41741

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libnginx-mod-rtmp, p-cpe:/a:debian:debian_linux:nginx-common, p-cpe:/a:debian:debian_linux:libnginx-mod-nchan, p-cpe:/a:debian:debian_linux:libnginx-mod-http-cache-purge, p-cpe:/a:debian:debian_linux:nginx-full, cpe:/o:debian:debian_linux:10.0, p-cpe:/a:debian:debian_linux:libnginx-mod-http-image-filter, p-cpe:/a:debian:debian_linux:libnginx-mod-http-upstream-fair, p-cpe:/a:debian:debian_linux:libnginx-mod-http-lua, p-cpe:/a:debian:debian_linux:libnginx-mod-http-subs-filter, p-cpe:/a:debian:debian_linux:libnginx-mod-stream, p-cpe:/a:debian:debian_linux:nginx-doc, p-cpe:/a:debian:debian_linux:libnginx-mod-http-ndk, p-cpe:/a:debian:debian_linux:libnginx-mod-http-headers-more-filter, p-cpe:/a:debian:debian_linux:libnginx-mod-http-uploadprogress, p-cpe:/a:debian:debian_linux:libnginx-mod-http-dav-ext, p-cpe:/a:debian:debian_linux:libnginx-mod-mail, p-cpe:/a:debian:debian_linux:nginx, p-cpe:/a:debian:debian_linux:libnginx-mod-http-auth-pam, p-cpe:/a:debian:debian_linux:libnginx-mod-http-fancyindex, p-cpe:/a:debian:debian_linux:nginx-light, p-cpe:/a:debian:debian_linux:libnginx-mod-http-xslt-filter, p-cpe:/a:debian:debian_linux:nginx-extras, p-cpe:/a:debian:debian_linux:libnginx-mod-http-echo, p-cpe:/a:debian:debian_linux:libnginx-mod-http-geoip, p-cpe:/a:debian:debian_linux:libnginx-mod-http-perl

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 11/23/2022

Vulnerability Publication Date: 10/25/2021

Reference Information

CVE: CVE-2021-3618, CVE-2022-41741, CVE-2022-41742

IAVA: 2022-A-0440-S