Ubuntu 16.04 ESM / 18.04 LTS / 20.04 LTS / 22.04 LTS / 22.10 : Expat vulnerability (USN-5638-3)

high Nessus Plugin ID 168153

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 16.04 ESM / 18.04 LTS / 20.04 LTS / 22.04 LTS / 22.10 host has packages installed that are affected by a vulnerability as referenced in the USN-5638-3 advisory.

- In libexpat through 2.4.9, there is a use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate in out-of-memory situations. (CVE-2022-43680)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5638-3

Plugin Details

Severity: High

ID: 168153

File Name: ubuntu_USN-5638-3.nasl

Version: 1.2

Type: local

Agent: unix

Published: 11/23/2022

Updated: 11/23/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

Risk Information

VPR

Risk Factor: Medium

Score: 6.1

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-43680

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:canonical:ubuntu_linux:18.04:-:lts:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:20.04:-:lts:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:lib64expat1:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libexpat1:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:expat:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:lib64expat1-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libexpat1-dev:*:*:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:22.04:-:lts:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:16.04:-:esm:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:22.10:*:*:*:*:*:*:*

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 11/23/2022

Vulnerability Publication Date: 10/24/2022

Reference Information

CVE: CVE-2022-43680

USN: 5638-3