Ubuntu 16.04 ESM / 18.04 LTS / 20.04 LTS / 22.04 LTS : X.Org X Server vulnerabilities (USN-5740-1)

high Nessus Plugin ID 168152

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 16.04 ESM / 18.04 LTS / 20.04 LTS / 22.04 LTS host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5740-1 advisory.

- A vulnerability classified as critical was found in X.org Server. Affected by this vulnerability is the function _GetCountedString of the file xkb/xkb.c. The manipulation leads to buffer overflow. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-211051. (CVE-2022-3550)

- A vulnerability, which was classified as problematic, has been found in X.org Server. Affected by this issue is the function ProcXkbGetKbdByName of the file xkb/xkb.c. The manipulation leads to memory leak. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-211052.
(CVE-2022-3551)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5740-1

Plugin Details

Severity: High

ID: 168152

File Name: ubuntu_USN-5740-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 11/23/2022

Updated: 11/23/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-3550

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:canonical:ubuntu_linux:18.04:-:lts:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:20.04:-:lts:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-core:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-core-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xdmx:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xdmx-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xnest:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xephyr:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xvfb:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-common:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-core-hwe-18.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xmir:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xmir-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xorg-server-source:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xorg-server-source-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xorg-server-source-hwe-18.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xephyr-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xephyr-hwe-18.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-dev-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-dev-hwe-18.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-legacy:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-legacy-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-legacy-hwe-18.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xserver-xorg-xmir:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xwayland:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xwayland-hwe-16.04:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:xwayland-hwe-18.04:*:*:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:22.04:-:lts:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:16.04:-:esm:*:*:*:*:*

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 11/23/2022

Vulnerability Publication Date: 10/17/2022

Reference Information

CVE: CVE-2022-3551, CVE-2022-3550

USN: 5740-1