Ubuntu 16.04 ESM : APR-util vulnerability (USN-5737-1)

medium Nessus Plugin ID 168150

Synopsis

The remote Ubuntu host is missing a security update.

Description

The remote Ubuntu 16.04 ESM host has packages installed that are affected by a vulnerability as referenced in the USN-5737-1 advisory.

- Apache Portable Runtime Utility (APR-util) 1.6.0 and prior fail to validate the integrity of SDBM database files used by apr_sdbm*() functions, resulting in a possible out of bound read access. A local user with write access to the database can make a program or process using these functions crash, and cause a denial of service. (CVE-2017-12618)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5737-1

Plugin Details

Severity: Medium

ID: 168150

File Name: ubuntu_USN-5737-1.nasl

Version: 1.2

Type: local

Agent: unix

Published: 11/23/2022

Updated: 11/23/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Low

Base Score: 1.9

Temporal Score: 1.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2017-12618

CVSS v3

Risk Factor: Medium

Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1-dbd-mysql:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1-dbd-odbc:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1-dbd-pgsql:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1-dbd-sqlite3:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:canonical:ubuntu_linux:libaprutil1-ldap:*:*:*:*:*:*:*, cpe:2.3:o:canonical:ubuntu_linux:16.04:-:esm:*:*:*:*:*

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Ease: No known exploits are available

Patch Publication Date: 11/23/2022

Vulnerability Publication Date: 10/23/2017

Reference Information

CVE: CVE-2017-12618

USN: 5737-1