Samba < 4.15.12, 4.16.x < 4.16.7, and 4.17.x < 4.17.3 32-Bit Systems Buffer Overflow

high Nessus Plugin ID 168018


The remote Samba server is potentially affected by a buffer overflow vulnerability


The version of Samba running on the remote host is prior to 4.15.12, 4.16.x prior to 4.16.7, or 4.17.x prior to 4.17.3.
It is, therefore, potentially affected by a buffer overflow condition in the bundled Kerberos libraries due to a miss calculation of bytes to allocate for a buffer. An authenticated, remote attacker can exploit this, via a specially crafted ticket containing Privilege Attribute Certificates, to cause a denial of service condition or read beyond the memory bounds.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Samba version 4.15.12, 4.16.7, 4.17.3 or later.

See Also

Plugin Details

Severity: High

ID: 168018

File Name: samba_cve_2022-42898.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 11/21/2022

Updated: 1/6/2023

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-42898


Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

Required KB Items: SMB/samba, SMB/NativeLanManager

Exploit Ease: No known exploits are available

Patch Publication Date: 11/15/2022

Vulnerability Publication Date: 11/15/2022

Reference Information

CVE: CVE-2022-42898

IAVA: 2022-A-0495-S