Debian DLA-3198-1 : php-phpseclib - LTS security update

high Nessus Plugin ID 167912


The remote Debian host is missing a security-related update.


The remote Debian 10 host has a package installed that is affected by a vulnerability as referenced in the dla-3198 advisory.

- phpseclib before 2.0.31 and 3.x before 3.0.7 mishandles RSA PKCS#1 v1.5 signature verification.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the php-phpseclib packages.

For Debian 10 buster, this problem has been fixed in version 2.0.30-2~deb10u1.

See Also

Plugin Details

Severity: High

ID: 167912

File Name: debian_DLA-3198.nasl

Version: 1.2

Type: local

Agent: unix

Published: 11/18/2022

Updated: 11/18/2022

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2021-30130


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php-phpseclib, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 11/17/2022

Vulnerability Publication Date: 4/6/2021

Reference Information

CVE: CVE-2021-30130