Debian DSA-5280-1 : grub2 - security update

high Nessus Plugin ID 167746

Synopsis

The remote Debian host is missing one or more security-related updates.

Description

The remote Debian 11 host has packages installed that are affected by multiple vulnerabilities as referenced in the dsa-5280 advisory.

- grub2: Buffer overflow in grub_font_construct_glyph() can lead to out-of-bound write and possible secure boot bypass (CVE-2022-2601)

- grub2: Heap based out-of-bounds write when redering certain unicode sequences (CVE-2022-3775)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the grub2 packages.

For the stable distribution (bullseye), these problems have been fixed in version 2.06-3~deb11u4.

See Also

https://security-tracker.debian.org/tracker/CVE-2022-2601

https://security-tracker.debian.org/tracker/CVE-2022-3775

https://packages.debian.org/source/bullseye/grub2

https://security-tracker.debian.org/tracker/source-package/grub2

https://www.debian.org/security/2022/dsa-5280

Plugin Details

Severity: High

ID: 167746

File Name: debian_DSA-5280.nasl

Version: 1.4

Type: local

Agent: unix

Published: 11/16/2022

Updated: 10/3/2023

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-2601

CVSS v3

Risk Factor: High

Base Score: 8.6

Temporal Score: 7.7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:grub-common, p-cpe:/a:debian:debian_linux:grub-coreboot, p-cpe:/a:debian:debian_linux:grub-coreboot-bin, p-cpe:/a:debian:debian_linux:grub-coreboot-dbg, p-cpe:/a:debian:debian_linux:grub-efi, p-cpe:/a:debian:debian_linux:grub-efi-amd64, p-cpe:/a:debian:debian_linux:grub-efi-amd64-bin, p-cpe:/a:debian:debian_linux:grub-efi-amd64-dbg, p-cpe:/a:debian:debian_linux:grub-efi-amd64-signed-template, p-cpe:/a:debian:debian_linux:grub-efi-arm, p-cpe:/a:debian:debian_linux:grub-efi-arm-bin, p-cpe:/a:debian:debian_linux:grub-efi-arm-dbg, p-cpe:/a:debian:debian_linux:grub-efi-arm64, p-cpe:/a:debian:debian_linux:grub-efi-arm64-bin, p-cpe:/a:debian:debian_linux:grub-efi-arm64-dbg, p-cpe:/a:debian:debian_linux:grub-efi-arm64-signed-template, p-cpe:/a:debian:debian_linux:grub-efi-ia32, p-cpe:/a:debian:debian_linux:grub-efi-ia32-bin, p-cpe:/a:debian:debian_linux:grub-efi-ia32-dbg, p-cpe:/a:debian:debian_linux:grub-efi-ia32-signed-template, p-cpe:/a:debian:debian_linux:grub-emu, p-cpe:/a:debian:debian_linux:grub-emu-dbg, p-cpe:/a:debian:debian_linux:grub-firmware-qemu, p-cpe:/a:debian:debian_linux:grub-ieee1275, p-cpe:/a:debian:debian_linux:grub-ieee1275-bin, p-cpe:/a:debian:debian_linux:grub-ieee1275-dbg, p-cpe:/a:debian:debian_linux:grub-linuxbios, p-cpe:/a:debian:debian_linux:grub-mount-udeb, p-cpe:/a:debian:debian_linux:grub-pc, p-cpe:/a:debian:debian_linux:grub-pc-bin, p-cpe:/a:debian:debian_linux:grub-pc-dbg, p-cpe:/a:debian:debian_linux:grub-rescue-pc, p-cpe:/a:debian:debian_linux:grub-theme-starfield, p-cpe:/a:debian:debian_linux:grub-uboot, p-cpe:/a:debian:debian_linux:grub-uboot-bin, p-cpe:/a:debian:debian_linux:grub-uboot-dbg, p-cpe:/a:debian:debian_linux:grub-xen, p-cpe:/a:debian:debian_linux:grub-xen-bin, p-cpe:/a:debian:debian_linux:grub-xen-dbg, p-cpe:/a:debian:debian_linux:grub-xen-host, p-cpe:/a:debian:debian_linux:grub-yeeloong, p-cpe:/a:debian:debian_linux:grub-yeeloong-bin, p-cpe:/a:debian:debian_linux:grub-yeeloong-dbg, p-cpe:/a:debian:debian_linux:grub2, p-cpe:/a:debian:debian_linux:grub2-common, cpe:/o:debian:debian_linux:11.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/15/2022

Vulnerability Publication Date: 11/16/2022

Reference Information

CVE: CVE-2022-2601, CVE-2022-3775