Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS : PHP vulnerabilities (USN-5717-1)

critical Nessus Plugin ID 167197

Synopsis

The remote Ubuntu host is missing one or more security updates.

Description

The remote Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS / 22.10 host has packages installed that are affected by multiple vulnerabilities as referenced in the USN-5717-1 advisory.

- In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress quines gzip files, resulting in an infinite loop. (CVE-2022-31628)

- In PHP versions before 7.4.31, 8.0.24 and 8.1.11, the vulnerability enables network and same-site attackers to set a standard insecure cookie in the victim's browser which is treated as a `__Host-` or `__Secure-` cookie by PHP applications. (CVE-2022-31629)

- The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to execute arbitrary code or eliminate expected cryptographic properties.
This occurs in the sponge function interface. (CVE-2022-37454)

- The vulnerability exists due to a boundary condition within the imageloadfont() function. A remote attacker can pass specially crafted data to the web application, trigger an out-of-bounds read error and read contents of memory on the system. (CVE-2022-31630)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected packages.

See Also

https://ubuntu.com/security/notices/USN-5717-1

Plugin Details

Severity: Critical

ID: 167197

File Name: ubuntu_USN-5717-1.nasl

Version: 1.9

Type: local

Agent: unix

Published: 11/9/2022

Updated: 10/16/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-37454

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:libapache2-mod-php7.2, p-cpe:/a:canonical:ubuntu_linux:libapache2-mod-php7.4, p-cpe:/a:canonical:ubuntu_linux:libapache2-mod-php8.0, p-cpe:/a:canonical:ubuntu_linux:libapache2-mod-php8.1, p-cpe:/a:canonical:ubuntu_linux:libphp7.2-embed, p-cpe:/a:canonical:ubuntu_linux:libphp7.4-embed, p-cpe:/a:canonical:ubuntu_linux:libphp8.1-embed, p-cpe:/a:canonical:ubuntu_linux:php7.2, p-cpe:/a:canonical:ubuntu_linux:php7.2-bcmath, p-cpe:/a:canonical:ubuntu_linux:php7.2-bz2, p-cpe:/a:canonical:ubuntu_linux:php7.2-cgi, p-cpe:/a:canonical:ubuntu_linux:php7.2-cli, p-cpe:/a:canonical:ubuntu_linux:php7.2-common, p-cpe:/a:canonical:ubuntu_linux:php7.2-curl, p-cpe:/a:canonical:ubuntu_linux:php7.2-dba, p-cpe:/a:canonical:ubuntu_linux:php7.2-dev, p-cpe:/a:canonical:ubuntu_linux:php7.2-enchant, p-cpe:/a:canonical:ubuntu_linux:php7.2-fpm, p-cpe:/a:canonical:ubuntu_linux:php7.2-gd, p-cpe:/a:canonical:ubuntu_linux:php7.2-gmp, p-cpe:/a:canonical:ubuntu_linux:php7.2-imap, p-cpe:/a:canonical:ubuntu_linux:php7.2-interbase, p-cpe:/a:canonical:ubuntu_linux:php7.2-intl, p-cpe:/a:canonical:ubuntu_linux:php7.2-json, p-cpe:/a:canonical:ubuntu_linux:php7.2-ldap, p-cpe:/a:canonical:ubuntu_linux:php7.2-mbstring, p-cpe:/a:canonical:ubuntu_linux:php7.2-mysql, p-cpe:/a:canonical:ubuntu_linux:php7.2-odbc, p-cpe:/a:canonical:ubuntu_linux:php7.2-opcache, p-cpe:/a:canonical:ubuntu_linux:php7.2-pgsql, p-cpe:/a:canonical:ubuntu_linux:php7.2-phpdbg, p-cpe:/a:canonical:ubuntu_linux:php7.2-pspell, p-cpe:/a:canonical:ubuntu_linux:php8.1-sybase, p-cpe:/a:canonical:ubuntu_linux:php8.1-tidy, p-cpe:/a:canonical:ubuntu_linux:php8.1-xml, p-cpe:/a:canonical:ubuntu_linux:php8.1-xsl, p-cpe:/a:canonical:ubuntu_linux:php8.1-zip, p-cpe:/a:canonical:ubuntu_linux:php7.2-readline, p-cpe:/a:canonical:ubuntu_linux:php7.2-recode, p-cpe:/a:canonical:ubuntu_linux:php7.2-snmp, p-cpe:/a:canonical:ubuntu_linux:php7.2-soap, p-cpe:/a:canonical:ubuntu_linux:php7.2-sqlite3, p-cpe:/a:canonical:ubuntu_linux:php7.2-sybase, p-cpe:/a:canonical:ubuntu_linux:php7.2-tidy, p-cpe:/a:canonical:ubuntu_linux:php7.2-xml, p-cpe:/a:canonical:ubuntu_linux:php7.2-xmlrpc, p-cpe:/a:canonical:ubuntu_linux:php7.2-xsl, p-cpe:/a:canonical:ubuntu_linux:php7.2-zip, p-cpe:/a:canonical:ubuntu_linux:php7.4, p-cpe:/a:canonical:ubuntu_linux:php7.4-bcmath, p-cpe:/a:canonical:ubuntu_linux:php7.4-bz2, p-cpe:/a:canonical:ubuntu_linux:php7.4-cgi, p-cpe:/a:canonical:ubuntu_linux:php7.4-cli, p-cpe:/a:canonical:ubuntu_linux:php7.4-common, p-cpe:/a:canonical:ubuntu_linux:php7.4-curl, p-cpe:/a:canonical:ubuntu_linux:php7.4-dba, p-cpe:/a:canonical:ubuntu_linux:php7.4-dev, p-cpe:/a:canonical:ubuntu_linux:php7.4-enchant, p-cpe:/a:canonical:ubuntu_linux:php7.4-fpm, p-cpe:/a:canonical:ubuntu_linux:php7.4-gd, p-cpe:/a:canonical:ubuntu_linux:php7.4-gmp, p-cpe:/a:canonical:ubuntu_linux:php7.4-imap, p-cpe:/a:canonical:ubuntu_linux:php7.4-interbase, p-cpe:/a:canonical:ubuntu_linux:php7.4-intl, p-cpe:/a:canonical:ubuntu_linux:php7.4-json, p-cpe:/a:canonical:ubuntu_linux:php7.4-ldap, p-cpe:/a:canonical:ubuntu_linux:php7.4-mbstring, p-cpe:/a:canonical:ubuntu_linux:php7.4-mysql, p-cpe:/a:canonical:ubuntu_linux:php7.4-odbc, p-cpe:/a:canonical:ubuntu_linux:php7.4-opcache, p-cpe:/a:canonical:ubuntu_linux:php7.4-pgsql, p-cpe:/a:canonical:ubuntu_linux:php7.4-phpdbg, p-cpe:/a:canonical:ubuntu_linux:php7.4-pspell, p-cpe:/a:canonical:ubuntu_linux:php7.4-readline, p-cpe:/a:canonical:ubuntu_linux:php7.4-snmp, p-cpe:/a:canonical:ubuntu_linux:php7.4-soap, p-cpe:/a:canonical:ubuntu_linux:php7.4-sqlite3, p-cpe:/a:canonical:ubuntu_linux:php7.4-sybase, p-cpe:/a:canonical:ubuntu_linux:php7.4-tidy, p-cpe:/a:canonical:ubuntu_linux:php7.4-xml, p-cpe:/a:canonical:ubuntu_linux:php7.4-xmlrpc, p-cpe:/a:canonical:ubuntu_linux:php7.4-xsl, p-cpe:/a:canonical:ubuntu_linux:php7.4-zip, p-cpe:/a:canonical:ubuntu_linux:php8.1, p-cpe:/a:canonical:ubuntu_linux:php8.1-bcmath, p-cpe:/a:canonical:ubuntu_linux:php8.1-bz2, p-cpe:/a:canonical:ubuntu_linux:php8.1-cgi, p-cpe:/a:canonical:ubuntu_linux:php8.1-cli, p-cpe:/a:canonical:ubuntu_linux:php8.1-common, p-cpe:/a:canonical:ubuntu_linux:php8.1-curl, p-cpe:/a:canonical:ubuntu_linux:php8.1-dba, p-cpe:/a:canonical:ubuntu_linux:php8.1-dev, p-cpe:/a:canonical:ubuntu_linux:php8.1-enchant, p-cpe:/a:canonical:ubuntu_linux:php8.1-fpm, p-cpe:/a:canonical:ubuntu_linux:php8.1-gd, p-cpe:/a:canonical:ubuntu_linux:php8.1-gmp, p-cpe:/a:canonical:ubuntu_linux:php8.1-imap, p-cpe:/a:canonical:ubuntu_linux:php8.1-interbase, p-cpe:/a:canonical:ubuntu_linux:php8.1-intl, p-cpe:/a:canonical:ubuntu_linux:php8.1-ldap, p-cpe:/a:canonical:ubuntu_linux:php8.1-mbstring, p-cpe:/a:canonical:ubuntu_linux:php8.1-mysql, p-cpe:/a:canonical:ubuntu_linux:php8.1-odbc, p-cpe:/a:canonical:ubuntu_linux:php8.1-opcache, p-cpe:/a:canonical:ubuntu_linux:php8.1-pgsql, p-cpe:/a:canonical:ubuntu_linux:php8.1-phpdbg, p-cpe:/a:canonical:ubuntu_linux:php8.1-pspell, p-cpe:/a:canonical:ubuntu_linux:php8.1-readline, p-cpe:/a:canonical:ubuntu_linux:php8.1-snmp, p-cpe:/a:canonical:ubuntu_linux:php8.1-soap, p-cpe:/a:canonical:ubuntu_linux:php8.1-sqlite3

Required KB Items: Host/cpu, Host/Debian/dpkg-l, Host/Ubuntu, Host/Ubuntu/release

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/8/2022

Vulnerability Publication Date: 9/28/2022

Reference Information

CVE: CVE-2022-31628, CVE-2022-31629, CVE-2022-31630, CVE-2022-37454

IAVA: 2022-A-0515-S

USN: 5717-1