CentOS 8 : httpd:2.4 (CESA-2022:7647)

critical Nessus Plugin ID 167180

Synopsis

The remote CentOS host is missing one or more security updates.

Description

The remote CentOS Linux 8 host has packages installed that are affected by multiple vulnerabilities as referenced in the CESA-2022:7647 advisory.

- httpd: mod_lua: Use of uninitialized value of in r:parsebody (CVE-2022-22719)

- httpd: core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody (CVE-2022-22721)

- httpd: mod_sed: Read/write beyond bounds (CVE-2022-23943)

- httpd: mod_proxy_ajp: Possible request smuggling (CVE-2022-26377)

- httpd: Out-of-bounds read via ap_rwrite() (CVE-2022-28614)

- httpd: Out-of-bounds read in ap_strcmp_match() (CVE-2022-28615)

- httpd: mod_lua: DoS in r:parsebody (CVE-2022-29404)

- httpd: mod_sed: DoS vulnerability (CVE-2022-30522)

- httpd: mod_lua: Information disclosure with websockets (CVE-2022-30556)

- httpd: mod_proxy: X-Forwarded-For dropped by hop-by-hop mechanism (CVE-2022-31813)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update the affected mod_http2 and / or mod_md packages.

See Also

https://access.redhat.com/errata/RHSA-2022:7647

Plugin Details

Severity: Critical

ID: 167180

File Name: centos8_RHSA-2022-7647.nasl

Version: 1.4

Type: local

Agent: unix

Published: 11/9/2022

Updated: 10/5/2023

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.0

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2022-31813

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:mod_http2, p-cpe:/a:centos:centos:mod_md

Required KB Items: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/8/2022

Vulnerability Publication Date: 3/14/2022

Reference Information

CVE: CVE-2022-22719, CVE-2022-22721, CVE-2022-23943, CVE-2022-26377, CVE-2022-28614, CVE-2022-28615, CVE-2022-29404, CVE-2022-30522, CVE-2022-30556, CVE-2022-31813

RHSA: 2022:7647