Amazon Linux 2022 : (ALAS2022-2022-190)

high Nessus Plugin ID 167014

Synopsis

The remote Amazon Linux 2022 host is missing a security update.

Description

It is, therefore, affected by a vulnerability as referenced in the ALAS2022-2022-190 advisory.

- A flaw was found in PostgreSQL. There is an issue with incomplete efforts to operate safely when a privileged user is maintaining another user's objects. The Autovacuum, REINDEX, CREATE INDEX, REFRESH MATERIALIZED VIEW, CLUSTER, and pg_amcheck commands activated relevant protections too late or not at all during the process. This flaw allows an attacker with permission to create non-temporary objects in at least one schema to execute arbitrary SQL functions under a superuser identity. (CVE-2022-1552)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'dnf update postgresql14 --releasever=2022.0.20221102' to update your system.

See Also

https://alas.aws.amazon.com/AL2022/ALAS-2022-190.html

https://alas.aws.amazon.com/cve/html/CVE-2022-1552.html

Plugin Details

Severity: High

ID: 167014

File Name: al2022_ALAS2022-2022-190.nasl

Version: 1.4

Type: local

Agent: unix

Published: 11/5/2022

Updated: 11/28/2022

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS Score Source: CVE-2022-1552

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:postgresql14, p-cpe:/a:amazon:linux:postgresql14-contrib, p-cpe:/a:amazon:linux:postgresql14-contrib-debuginfo, p-cpe:/a:amazon:linux:postgresql14-debuginfo, p-cpe:/a:amazon:linux:postgresql14-debugsource, p-cpe:/a:amazon:linux:postgresql14-docs, p-cpe:/a:amazon:linux:postgresql14-upgrade-devel-debuginfo, cpe:/o:amazon:linux:2022, p-cpe:/a:amazon:linux:postgresql14-docs-debuginfo, p-cpe:/a:amazon:linux:postgresql14-llvmjit, p-cpe:/a:amazon:linux:postgresql14-llvmjit-debuginfo, p-cpe:/a:amazon:linux:postgresql14-plperl, p-cpe:/a:amazon:linux:postgresql14-plperl-debuginfo, p-cpe:/a:amazon:linux:postgresql14-plpython3, p-cpe:/a:amazon:linux:postgresql14-plpython3-debuginfo, p-cpe:/a:amazon:linux:postgresql14-pltcl, p-cpe:/a:amazon:linux:postgresql14-pltcl-debuginfo, p-cpe:/a:amazon:linux:postgresql14-private-devel, p-cpe:/a:amazon:linux:postgresql14-private-libs, p-cpe:/a:amazon:linux:postgresql14-private-libs-debuginfo, p-cpe:/a:amazon:linux:postgresql14-server, p-cpe:/a:amazon:linux:postgresql14-server-debuginfo, p-cpe:/a:amazon:linux:postgresql14-server-devel, p-cpe:/a:amazon:linux:postgresql14-server-devel-debuginfo, p-cpe:/a:amazon:linux:postgresql14-static, p-cpe:/a:amazon:linux:postgresql14-test, p-cpe:/a:amazon:linux:postgresql14-test-debuginfo, p-cpe:/a:amazon:linux:postgresql14-test-rpm-macros, p-cpe:/a:amazon:linux:postgresql14-upgrade, p-cpe:/a:amazon:linux:postgresql14-upgrade-debuginfo, p-cpe:/a:amazon:linux:postgresql14-upgrade-devel

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Ease: No known exploits are available

Patch Publication Date: 11/1/2022

Vulnerability Publication Date: 5/11/2022

Reference Information

CVE: CVE-2022-1552

IAVB: 2022-B-0015-S