Amazon Linux 2022 : (ALAS2022-2022-167)

low Nessus Plugin ID 166986

Synopsis

The remote Amazon Linux 2022 host is missing a security update.

Description

It is, therefore, affected by a vulnerability as referenced in the ALAS2022-2022-167 advisory.

- Buffer overflow vulnerability in libsolv 2020-12-13 via the Solver * testcase_read(Pool *pool, FILE *fp, const char *testcase, Queue *job, char **resultp, int *resultflagsp function at src/testcase.c: line 2334, which could cause a denial of service (CVE-2021-3200)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Run 'dnf update libsolv --releasever=2022.0.20221102' to update your system.

See Also

https://alas.aws.amazon.com/AL2022/ALAS-2022-167.html

https://alas.aws.amazon.com/cve/html/CVE-2021-3200.html

Plugin Details

Severity: Low

ID: 166986

File Name: al2022_ALAS2022-2022-167.nasl

Version: 1.3

Type: local

Agent: unix

Published: 11/4/2022

Updated: 10/5/2023

Supported Sensors: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information

VPR

Risk Factor: Low

Score: 2.2

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS Score Source: CVE-2021-3200

CVSS v3

Risk Factor: Low

Base Score: 3.3

Temporal Score: 3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:libsolv, p-cpe:/a:amazon:linux:libsolv-debuginfo, p-cpe:/a:amazon:linux:libsolv-debugsource, p-cpe:/a:amazon:linux:libsolv-demo, p-cpe:/a:amazon:linux:libsolv-demo-debuginfo, p-cpe:/a:amazon:linux:libsolv-devel, p-cpe:/a:amazon:linux:libsolv-tools, p-cpe:/a:amazon:linux:libsolv-tools-debuginfo, p-cpe:/a:amazon:linux:perl-solv, p-cpe:/a:amazon:linux:perl-solv-debuginfo, p-cpe:/a:amazon:linux:python3-solv, p-cpe:/a:amazon:linux:python3-solv-debuginfo, p-cpe:/a:amazon:linux:ruby-solv, p-cpe:/a:amazon:linux:ruby-solv-debuginfo, cpe:/o:amazon:linux:2022

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/1/2022

Vulnerability Publication Date: 5/18/2021

Reference Information

CVE: CVE-2021-3200